Monthly Archive September 2016

Fortinet FortiGate – Befehle

Fortinet bietet mit der Produktfamilie „FortiGate“ eine ganze Palette von mehrfach ausgezeichneten Appliances für den Schutz von Netzwerken.

 

Zum aktivieren des Traces loggen wir uns via Putty auf die Firewall.

Flow Trace zum debuggen (traced den transfer zu 51.22.0.123)

#deaktiviert und reset aktuelle Filter und Traces
diagnose debug disable 
diagnose debug flow trace stop 
diagnose debug flow filter clear 
diagnose debug reset 

#aktiviert die neuen Filter und Traces
diagnose debug flow filter addr  51.22.0.123
diagnose debug flow show console enable
diagnose debug flow show function-name enable
diagnose debug console timestamp enable
diagnose debug flow trace start 999
diagnose debug enable

 

Flow Trace zum debuggen (traced den transfer von 10.1.0.1)

#deaktiviert und reset aktuelle Filter und Traces
diagnose debug disable 
diagnose debug flow trace stop 
diagnose debug flow filter clear 
diagnose debug reset 

#aktiviert die neuen Filter und Traces
diagnose debug flow filter saddr  10.1.0.1
diagnose debug flow show console enable
diagnose debug flow show function-name enable
diagnose debug console timestamp enable
diagnose debug flow trace start 999
diagnose debug enable

 

Flow Trace zum debuggen (traced den transfer von 10.1.0.1 an 51.22.0.123)

#deaktiviert und reset aktuelle Filter und Traces
diagnose debug disable 
diagnose debug flow trace stop 
diagnose debug flow filter clear 
diagnose debug reset 

#aktiviert die neuen Filter und Traces
diagnose debug flow filter saddr  10.1.0.1
diagnose debug flow filter addr  51.22.0.123
diagnose debug flow show console enable
diagnose debug flow show function-name enable
diagnose debug console timestamp enable
diagnose debug flow trace start 999
diagnose debug enable

Ping ausführen

execute ping web.de

Trace Route ausführen

execute traceroute web.de

 

Befehle HP Switch 5900 mit Comware

Comware besitzt keine GUI. Der Switch muß also komplett über die CLI konfiguriert und administriert werden. Aber mit etwas Übung kann man sich schnell einarbeiten.
Als erstes sollte man das Konfigurationskabel an den Konsolenport anschließen und über die Konsole sich mit dem Switch verbinden. Hierzu kann das Programm „Putty“ verwendet werden.

 

Config modus aktivieren <Coreswitch> -> [Coreswitch]

system-view

Aktuelle Config anzeigen lassen

display current-configuration

Aktuelle Config eines Ports anzeigen lassen

display current-configuration interface GigabitEthernet 1/0/32

Neues VLAN erstellen

vlan 1337
name iscsi-new
quit

Alle VLAN´s incl. Ports anzeigen lassen

display vlan all

Alle VLAN´s ohne Ports anzeigen lassen

display vlan

Vorhandenes VLAN tagged auf einen Port legen

interface GigabitEthernet1/0/32
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 1332
exit

Vorhandes VLAN untagged auf einen Port legen

interface Ten-GigabitEthernet4/0/12
port link-mode bridge
port access vlan 1000
exit

Routing anzeigen lassen

display ip routing-table

Route/Standardgateway definieren

ip route-static 0.0.0.0 0.0.0.0 192.168.66.254

Port deaktivieren

interface GigabitEthernet1/0/32
shutdown

Port wieder aktivieren

undo shutdown

SSH aktivieren / abfragen:

ssh server enable
display ssh server status
display ssh server session

SSH public-key erstellen:

public-key local create rsa (-> hier können die Standardvorgaben verwendet werden)

SSH user anlegen und network-admin recht zuweisen:

user-interface vty 0 15 (-> hier wird in das Management Interface gewechselt)
authentication-mode scheme
protocol inbound ssh
quit
local-user Berlin (-> hier wird der User "Berlin" angelegt)
password simple 5678 (-> hier wird das Passwort "5678" gesetzt)
service-type ssh
authorization-attribute user-role network-admin
quit
save

Configuration sichern via tftp

backup startup-configuration to ip_des_tftp-Server configname.cfg

Firmware updaten (Firmware auf den Switch laden)

tftp ip_des_tftp-Servers get xxx.ipe (-> läd das ipe File in das Root-Verzeichnis)

Firmware File aktivieren

boot-loader file flash:/xxx.ipe slot 1 main

Switchname vergeben:

sysname coreswitch

config speichern

save force

Update von Icinga 2.4.x, 2.5.x, 2.6.0 auf Icinga 2.7.0

Edit: Da ich nicht jedes Update dokumentiere – hier eine Anleitung mit ggf. verschiedenen Versionen. Der Weg ist allerdings der gleiche 😀
Edit2: Beim Update auf 2.7.0 wird kein Shema-Update der Datenbank benötigt.

Icinga2 V2.5.4 ist da. Allerdings bin ich beim update direkt ins stocken geraten.
Daher beschreibe ich hier einmal den Weg – wie das Update funktioniert.

 

Im ersten Schritt führen wir das Update durch.

[root@vlicinga002 ~]# yum update

Abhängigkeiten aufgelöst

=====================================================================================================================================
 Package                           Arch                 Version                            Paketquelle                         Größe
=====================================================================================================================================
Installieren:
 kernel                            x86_64               3.10.0-327.28.3.el7                updates                              33 M
 kernel-devel                      x86_64               3.10.0-327.28.3.el7                updates                              11 M
Aktualisieren:
 icinga2                           x86_64               2.5.4-1.el7.centos                 icinga-stable-release               9.0 k
 icinga2-bin                       x86_64               2.5.4-1.el7.centos                 icinga-stable-release                92 k
 icinga2-common                    x86_64               2.5.4-1.el7.centos                 icinga-stable-release                99 k
 icinga2-ido-mysql                 x86_64               2.5.4-1.el7.centos                 icinga-stable-release               167 k
 kernel-headers                    x86_64               3.10.0-327.28.3.el7                updates                             3.2 M
 kernel-tools                      x86_64               3.10.0-327.28.3.el7                updates                             2.4 M
 kernel-tools-libs                 x86_64               3.10.0-327.28.3.el7                updates                             2.3 M
 nodejs                            x86_64               0.10.46-1.el7                      epel                                2.0 M
 perf                              x86_64               3.10.0-327.28.3.el7                updates                             3.3 M
 python                            x86_64               2.7.5-38.el7_2                     updates                              89 k
 python-libs                       x86_64               2.7.5-38.el7_2                     updates                             5.6 M
 python-perf                       x86_64               3.10.0-327.28.3.el7                updates                             2.4 M
 uwsgi                             x86_64               2.0.13.1-2.el7                     epel                                360 k
 uwsgi-plugin-carbon               x86_64               2.0.13.1-2.el7                     epel                                 23 k
 uwsgi-plugin-common               x86_64               2.0.13.1-2.el7                     epel                                 48 k
Als Abhängigkeiten installiert:
 icinga2-libs                      x86_64               2.5.4-1.el7.centos                 icinga-stable-release               2.7 M

Transaktionsübersicht
=====================================================================================================================================
Installieren    2 Pakete (+1 Abhängiges Paket)
Aktualisieren  15 Pakete

Danach muss das Datenbank-Schema ebenfalls geupdatet werden (dies passiert nicht automatisch)

[root@vlicinga002 ~]# mysql -u root -p icinga < /usr/share/icinga2-ido-mysql/schema/upgrade/2.5.0.sql
Enter password:

Der Ordnungshalber mache ich danach ein reboot – um zu testen ob alle Dienste sauber starten (denn nach dem Update sind nicht alle Dienste gestartet).

[root@vlicinga002 ~]# reboot

fertig 😀